Dashboard not displaying as expected in Monta Hub

Incident Report for Monta

Resolved

Dashboards are now back an operational.
Posted Nov 05, 2025 - 09:17 UTC

Monitoring

The root cause was an issue with an external system, which has now been resolved. Service recovery is in progress, and we expect to be fully operational shortly.
Posted Nov 05, 2025 - 09:04 UTC

Identified

Root cause is an issue with an external system that is already fixed and we should be back up soon.
Posted Nov 05, 2025 - 09:01 UTC
This incident affected: Monta Hub - Web Portal.