Hub - Increased Error Rate

Incident Report for Monta

Resolved

We are pleased to report that the issue affecting the Monta Hub web portal has been resolved and the platform is operating normally. We apologize for any inconvenience this may have caused. Please reach out to our support team if you continue to experience any problems.
Posted Aug 04, 2026 - 14:10 UTC

Investigating

We are currently investigating an increased error rate affecting the Monta Hub web portal. Some partners may experience issues loading or navigating certain pages. Our team is actively working to identify and resolve the issue.
Posted Aug 04, 2026 - 13:35 UTC
This incident affected: Monta Hub - Web Portal.