Monta Wallets unavailable

Incident Report for Monta

Monitoring

Monta wallets are operational. Withdrawals are still paused while we verify all systems

Thanks for your patience
Posted Sep 18, 2025 - 06:12 UTC

Identified

Due to an abundance of caution, access to your Monta wallet is still disabled. We expect to resolve this issue and re-enable access to your Monta wallet tomorrow morning.

Thank you for your patience
Posted Sep 17, 2025 - 19:51 UTC
This incident affects: Wallet.