Monta Hub - Service Disruption

Incident Report for Monta

Resolved

The Monta Hub is now operating normally. We apologize for the inconvenience this disruption may have caused. Thank you for your patience while our team worked to resolve the issue.
Posted Aug 01, 2026 - 16:48 UTC

Investigating

We are currently aware of an issue affecting the Monta Hub. Our engineering team is actively investigating and working to resolve this as quickly as possible. We apologize for any inconvenience and will provide further updates soon.
Posted Aug 01, 2026 - 16:32 UTC
This incident affected: Monta Hub - Web Portal.