Monta Hub down

Incident Report for Monta

Resolved

This incident has been resolved.
We are back to 100%.
Posted Sep 04, 2025 - 13:38 UTC

Monitoring

A fix has been implemented and the Monta Hub is back up and running.

We're monitoring the situation.
Posted Sep 04, 2025 - 13:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 04, 2025 - 13:18 UTC

Investigating

We are aware that the Monta Hub is currently down.
We are actively investigating the issue and trying to resolve it.
Posted Sep 04, 2025 - 13:14 UTC
This incident affected: Monta Hub - Web Portal.