We are currently investigating an issue with dashboards in Hub

Incident Report for Monta

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 12:12 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 15, 2025 - 12:05 UTC

Investigating

We are currently investigating a disruption affecting our Hub. This may result in dashboards not loading.

Our team is actively looking into the issue and will provide further updates as we learn more. Thank you for your understanding and patience.
Posted Sep 15, 2025 - 11:51 UTC
This incident affected: Monta Hub - Web Portal.